Back
Downtime
Downtime
Landa App is Unavailable
Started 22 Mar at 10:43am EDT, resolved 22 Mar at 11:16am EDT.
Landa API
Resolved
Issue has been resolved.
Posted 22 Mar at 11:16am EDT.
Created
We've identified an issue causing the Landa app to malfunction. The issue has been identified as a 3rd party service that is down. We are working on a resolution.
Posted 22 Mar at 10:43am EDT.